Java Mailing List Archive

http://www.ant-tasks.com/

Apache Ant Archive

» Ant Users List
» Ant Developers List
Can 't get env.HOSTNAME

Can 't get env.HOSTNAME

2006-11-17       - By Anderson, Rob (Global Trade)
Reply:     1     2     3     4     5     6     7     8     9     10     >>  

Are you running this locally or remotely. In other words are you logged
in to crimson-gecko.corp.upromise.com when you run "ant get-env" or are
you doing something like this...

ssh crimson-gecko.corp.upromise.com "ant get-env"

-Rob A

> -----Original Message-----
> From: EJ Ciramella [mailto:ejciramella@(protected)]
> Sent: Friday, November 17, 2006 8:27 AM
> To: user@(protected)
> Subject: Can't get env.HOSTNAME
>
> Hey guys, I'm trying to do something really simple - echo the
> machine name of the machine running this particular build script.
>
> Crazy thing is, I've seen this work well a billion times
> over, now it's not working...
>
> Here's what I have:
>
> <target name="get-env">
>    <property environment="env"/>
>    <echo message="${env.HOSTNAME}"/>  <-- since it's a unix
> box, this should work
>    <echo message="${env.NUMBER_OF_PROCESSORS}"/>
>    <echo message="${env.ANT_HOME}"/>
> </target>
>
> I have the others in there just to see if they work, and the
> only one that actuall echos out anything is the ant home one.
>
> What gives?
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@(protected)
For additional commands, e-mail: user-help@(protected)


©2008 ant-tasks.com - Jax Systems, LLC, U.S.A.